Текстовый файл содержит строки различной длины, содержащие только 
заглавные буквы латинского алфавита (ABC…Z). Будем называть цепочкой 
группу идущих подряд одинаковых букв в одной строке. Определите, 
сколько раз буква, образующая самую длинную цепочку в файле, встречается 
в строке, содержащей эту цепочку. Если в файле есть несколько цепочек 
одинаковой максимальной длины, нужно выбрать ту из них, для которой 
общее количество образующих цепочку букв в соответствующей строке 
будет больше.

f = open('D:/24.txt','r')
s = ''
sim, g = '', ''
maxC, maxL = 0, 0
for i in f:
    s = i
    LC = 1
    for a, b in zip(s, s[1:]):
        if a==b:
            LC+=1
        if (a!=b):
            if maxC<LC:
                maxC = LC
                maxL = s.count(a)
                sim = a
            elif maxC==LC:
                if maxL<s.count(a):
                    maxL = s.count(a)
                    sim=a
            LC=1
print(maxC, maxL,sim)